shopping cart empty
WORLDWIDE FREE SHIPPING

Leaking Bastard
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#31 (permalink)      5/23/2018 11:07:43 PM US Central   quote/reply + tips
Avatar
oilreg
Member
  • JoinedDec 2013
  • Posts 222
  • Reviews 128
  • Kudos58
+2 details
i contacted Wismec regarding this and they seem to care....
for now the where asking for S/N and stuff... will see what comes out of this, maybe we all can get the faulty ones replaced
#32 (permalink)      5/23/2018 11:32:45 PM US Central   quote/reply + tips
Avatar
JessVapin
Member
  • JoinedJan 2014
  • Posts 8551
  • Reviews 82
  • Kudos22300
+1 details
That's good news to hear they seem to care oilreg =) I'll also contact Wismec in the coming week, and I'll also report back with my experience to share. Let's see if we can get them to accept the unfortunate fact that the mod they produced is seriously flawed. =)
I'll be in and out.
#33 (permalink)      5/24/2018 1:03:29 AM US Central   quote/reply + tips
Avatar
Dandemonic
Member
  • JoinedMar 2016
  • Posts 259
  • Reviews 80
  • Kudos485
+1 details
I hope you both get an acceptable end result for your troubles, it's a chance for Wismec to take responsibility for defects in their products and regain some customer confidence.

I've been in touch over the past few days with fasttech customer service and they've been very helpful in organising a warranty refund to use towards another purchase, which was my preferred option.

As much as I like my Luxotic BF I don't want to risk a replacement having the same issue again, until there's certainty the mod 510 is adequately sealed.

Just waiting for my preferred choice to ship now.
BFYTW
#34 (permalink)      5/24/2018 1:46:12 AM US Central   quote/reply + tips
Avatar
oilreg
Member
  • JoinedDec 2013
  • Posts 222
  • Reviews 128
  • Kudos58
+2 details
@Dandemonic, thats sounds good as well, unfort. i didnt buy mine with FT that time.
#35 (permalink)      5/24/2018 2:00:13 AM US Central   quote/reply + tips
Avatar
JessVapin
Member
  • JoinedJan 2014
  • Posts 8551
  • Reviews 82
  • Kudos22300
+1 details
I like mine enough (less the leak) to hopefully get Wismec to replace it (if they will) with an updated 510. =)
But, kudos to fasttech for their CS.
I'll be in and out.
#36 (permalink)      5/24/2018 8:49:18 PM US Central   quote/reply + tips
Avatar
Irkme
Member
  • JoinedJun 2014
  • Posts 150
  • Reviews 2
  • Kudos83
$0.20 rebate earned+5 details
Not my video, just found it when I was searching google for any updates.

Mines still not arrived so can't confirm if this works but if the pins that slack no wonder it leaks.


#37 (permalink)      5/24/2018 9:11:27 PM US Central   quote/reply + tips
Avatar
JessVapin
Member
  • JoinedJan 2014
  • Posts 8551
  • Reviews 82
  • Kudos22300
+1 details
Great find, thanks for posting! =)

If this indeed is a fix, I think it's temporary as it'll wear and leak again in some time. But I may try this. =)
It's just a really poorly designed 510 in the end. Even if Wismec replaced my mod...temporary =(
I'll be in and out.
#38 (permalink)      5/29/2018 11:58:49 PM US Central   quote/reply + tips
Avatar
Dandemonic
Member
  • JoinedMar 2016
  • Posts 259
  • Reviews 80
  • Kudos485
PSA about mine...

Mine's definitely going in the bin now, it was only leaking a small amount with the Loop on it, so been using it a bit, without the cover plate so I could keep mopping up any moisture.

I haven't let moisture get on or near the board or button, since discovering the leak initially.

Twice now in the last two days it's kept firing by itself, after releasing the button, and despite the button clicking like it's disengaged fully.

Since the last "autofire" a few minutes ago it's firing by itself now, no light, no button activity, as soon as I put a battery in it.

Only way to stop it firing is rip the battery out. Button appears to be fully disengaged.

I've not disassembled it for confirmation of the actual cause yet, will do so after I make a video of it auto firing later today.

I'll try timing it later as well to see if there's any safety cut-off, doesn't seem to be but I didn't time it.

So it's getting binned for good after disassembly and I'm very glad I didn't go for a replacement of the same mod.

Edited on 5/30/2018 at 1:29 AM. Reason:
BFYTW
#39 (permalink)      5/30/2018 2:40:20 AM US Central   quote/reply + tips
Avatar
Dandemonic
Member
  • JoinedMar 2016
  • Posts 259
  • Reviews 80
  • Kudos485
+3 details
Here's a short vid of my Luxotic BF "auto firing".

I'm using Loop rda base with dual SS fused claptons 0.31 ohms, VTC5a battery (double wrapped), the tape around the battery is so I can definitley rip it out quickly if needed.

Apparently there's no time cut off feature as the mod fires for over 15 seconds, didn't want to go any longer to be nice to my battery. I tested it multiple times against a timer.

As soon as the battery is inserted the mod fires, and continues to do so unless battery is removed.

The switch is still very clicky and seems to be unbroken but has no effect on auto firing at all.

There is no juice visible in the area or on the board, which was my initial suspicion, but I will attempt a full disassembly and post pics of the PCB etc, probably in a new thread.



Edited on 5/30/2018 at 2:44 AM. Reason:
BFYTW
#40 (permalink)      5/30/2018 3:08:16 AM US Central   quote/reply + tips
Avatar
oilreg
Member
  • JoinedDec 2013
  • Posts 222
  • Reviews 128
  • Kudos58
the autofiring issue is insane
#41 (permalink)      5/30/2018 3:27:09 AM US Central   quote/reply + tips
Avatar
JessVapin
Member
  • JoinedJan 2014
  • Posts 8551
  • Reviews 82
  • Kudos22300
+2 details
Good greif, another issue I've gotta look forward to now. =( This sucks. ...and so does Wismec...
I'll be in and out.