shopping cart empty
WORLDWIDE FREE SHIPPING

Weird flooding problem?
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      1/19/2018 12:23:38 PM US Central   quote/reply + tips
Avatar
T_Bag
Member
  • JoinedSep 2015
  • Posts 611
  • Reviews 91
  • Kudos388
+1 details
Weird flooding problem?
Ok so I'm new to Kayfun styled RTAs, I basically bought this thing because it was cheap and I wanted to see what the hype was about. Well I understand, and this is my main vape now. But it has an odd problem (I think)...
Now I can wick it, put it together and close the juice flow control. Then I fill it, close the top, and reopen the JFC. And absolutely no problems. But as soon as I close the JFC again, the thing starts flooding, and a lot. Once I blow about a ml of juice out of the air hole it's fine, until the next time I close the JFC again. And yes this is happening without removing the top cap, and I've tried flipping it upside down to get all the juice away from the deck before closing the JFC... and it makes no difference.
Am I doing something wrong? Or is it a bad o-ring or a flawed atomizer? Has anyone else had this happen?

"Your words once heard, they can place you in a faction. My words may disturb, but at least there's a reaction."
#2 (permalink)      1/20/2018 6:35:26 AM US Central   quote/reply + tips
Steve_
Member
  • JoinedMar 2013
  • Posts 401
  • Reviews 16
  • Kudos280
+1 details
Giving you a bump here...

Don't really know what might be the issue here, the only situation where mine has a tendency to gurgle is when I open the jfc after refilling.

I noticed that the o-rings are starting to swell on mine, top cap is getting super tight to screw on, so I'll have to replace them. Might want to look into that.
#3 (permalink)      1/20/2018 6:43:15 AM US Central   quote/reply + tips
Avatar
gmm11
Member
  • JoinedMar 2016
  • Posts 4809
  • Reviews 178
  • Kudos5830
+2 details
it might be that when you close the juiceflow during normal use that its pushing some juice downwards creating the opposite of a vacuum ?, ive noticed this on my kf3 mini plus, only thing to do is just dont close the j/flow untill it needs filling, my last one, i close the j/flow and take a few drags on it to starve the cotton and when i refill, no gurgles, the other one, no gurgles at all,*shrugs, give it a try
#4 (permalink)      1/20/2018 6:52:49 AM US Central   quote/reply + tips
wuwei.ap
Member
  • JoinedMar 2015
  • Posts 22101
  • Reviews 266
  • Kudos42151
+6 details
When that happened on another Prime, it was the #11 o-ring being pushed out of the rim when the JFC was closed. It might be a bad o-ring. I swapped nearly all of mine for better ones because some had flashing although they still worked.



Edit:
Yeah, I invert before I closing/opening the JFC.

Edited on 1/20/2018 at 6:54 AM. Reason:
#5 (permalink)      1/20/2018 6:58:43 AM US Central   quote/reply + tips
Avatar
gmm11
Member
  • JoinedMar 2016
  • Posts 4809
  • Reviews 178
  • Kudos5830
+1 details
wonder if the same o ring is worth a look at on the kf3, should have plenty spares soon something is bound to be the same size
#6 (permalink)      1/20/2018 7:16:21 AM US Central   quote/reply + tips
Avatar
rangermsr
Member
  • JoinedJun 2013
  • Posts 7839
  • Reviews 29
  • Kudos11720
+1 details
I've had similar issues with that o-ring with the kv5, kv3.

That one will take the most wear. It's a good idea to buy replacements :)
unrealistic expectations lend to disappointment
#7 (permalink)      1/21/2018 5:06:04 PM US Central   quote/reply + tips
Avatar
T_Bag
Member
  • JoinedSep 2015
  • Posts 611
  • Reviews 91
  • Kudos388
+2 details
Thanks for the input. I'm going to try swapping out that o-ring on my nxt fill.
I have been vaping it down to empty to help the problem. I'll let you know how it works after the o-ring change.
"Your words once heard, they can place you in a faction. My words may disturb, but at least there's a reaction."
#8 (permalink)      1/25/2018 10:00:25 PM US Central   quote/reply + tips
pecemk
Member
  • JoinedOct 2017
  • Posts 41
  • Reviews 7
  • Kudos8
Same problem here, does changing the o-ring solves the problem?
#9 (permalink)      1/26/2018 11:07:52 PM US Central   quote/reply + tips
pecemk
Member
  • JoinedOct 2017
  • Posts 41
  • Reviews 7
  • Kudos8
I think it's same problem as flooding on SXK version it's o-ring 11, but not sure is the installed one too thin or too thick, will order [url=https://www.fasttech.com/p/9625157][/url] too try if will get any better,
Leaking is happening on refilling no matter what I try :(

Edited on 1/26/2018 at 11:12 PM. Reason:
#10 (permalink)      1/27/2018 1:11:50 AM US Central   quote/reply + tips
wuwei.ap
Member
  • JoinedMar 2015
  • Posts 22101
  • Reviews 266
  • Kudos42151
+4 details
If you just need to replace #11, SKU 2066600.
#11 (permalink)      1/27/2018 10:52:31 AM US Central   quote/reply + tips
pecemk
Member
  • JoinedOct 2017
  • Posts 41
  • Reviews 7
  • Kudos8
+1 details
wuwei.ap wrote:

If you just need to replace #11, SKU 2066600.


So this one is thinner than the one installed in YFTK?
I think that it's the problem, maybe even o-ring 10, don't know
But will order all the sizings :)
Thank you for helping...