shopping cart empty
WORLDWIDE FREE SHIPPING

Dead RBA ?
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      6/15/2017 6:51:48 AM US Central   quote/reply + tips
pewpewww
Member
  • JoinedNov 2015
  • Posts 8
  • Reviews 2
  • Kudos0
Dead RBA ?
Hey guys, my RBA got stuck and I had to use a vise to get the atomizer head out of the base, after I did that, I noticed the ohm reading on my alien 220w is not correct, it's way off (0.35ohm actual coil, 0.4-2ohm random reading). Then I checked the RBA and it's actually rotating even if it's in a fixed position. Here it's in a vise and you can see it rotates.

https://youtu.be/2SaDQ3YYRcE

Also, it does move up/down, right/left a bit, like it got loose. I imagine this is the reason it doesn't make perfect contact and shorts out. Best I could do is lock the resistance at 0.5ohm but after firing it for a few seconds, it says no coil until it cools down completely. I tried rotating the atomizer either way but didn't help.

Is this RBA dead or there is something I can do ?
#2 (permalink)      6/15/2017 8:34:58 PM US Central   quote/reply + tips
Avatar
Migweld
Member
  • JoinedOct 2014
  • Posts 1101
  • Reviews 0
  • Kudos475
Are the insulators under the post damaged or crushed? can you not open it now and take off the 2 post
there could be other parts that are damaged and thread also damaged
check orings on both parts and insulators
#3 (permalink)      6/16/2017 6:26:42 AM US Central   quote/reply + tips
pewpewww
Member
  • JoinedNov 2015
  • Posts 8
  • Reviews 2
  • Kudos0
How do you take off the 2 posts ? orings are fine and the threads too. the base is good, I just replaced the RBA with the premade coil heads for now.