shopping cart empty
Mine refuses to do 4*500ma
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      6/29/2015 6:06:22 AM US Central   quote/reply + tips
Hiko9
Member
  • JoinedJun 2013
  • Posts 5641
  • Reviews 269
  • Kudos5408
Mine refuses to do 4*500ma
Charging 4 Samsung 25Rs, as soon as i put the 4th cell in the charge current drops to 200ma
2 cells 2x1a fine
3 cells 3x500ma fine
4 cells 200ma max

Using the original cable and an apple 5.2v 2.4a 12w adaptor

Later on today i'm going out to get a replacement barrel plug and i'm going to solder up a usb lead with some stupidly thick wire and about 20cm long to see if that helps, if it doesn't, my unit is faulty

just thought i should warn people that there may either be a fault with some examples of this charger (so check yours) or it may need a better cable, i'll update this thread as i get results
Green Screwdriver for LIFE
#2 (permalink)      6/29/2015 6:09:40 AM US Central   quote/reply + tips
Avatar
Nymzavril
Member
  • JoinedApr 2014
  • Posts 23802
  • Reviews 280
  • Kudos18270
Good to know. Open a ticket and hopefully if anyone else has a similair problem, they'll chip in here. Mine has worked flawlessly, and Xtar is one of the Chinese electronics brands I tend to trust. Hopefully your issue is a one off.
Grand Poobah of The Sacred Order of The Magick Blue Screwdriver. The old Juice Junkies FAQ and guides can be found here: https://www.dropbox.com/sh/vp4ktp8l7fdywg5/AABFkmnUJhjl9vX8tE4URZ8sa?dl=0
#3 (permalink)      6/29/2015 6:13:23 AM US Central   quote/reply + tips
Avatar
Maui_Dave
Member
  • JoinedFeb 2015
  • Posts 3603
  • Reviews 69
  • Kudos4101
+1 details
I am using a 2.1a Samsung USB plug and mine charges all 4 ports at 500ma. Are you sure your charger plug is actually producing 2.4a? Sometimes the plug is rated to produce 2.4a but is actually faulty and not putting out the voltage it should.

Do you have one of these to test your wall plug? SKU 1859500

Edited on 6/29/2015 at 6:14 AM. Reason:
Flashlights: I put in a battery and press the button, if I can see again they work. If not I replace the battery. If that doesn't work I strip it down and turn it into a vape mod and get a new light.
#4 (permalink)      6/29/2015 6:13:28 AM US Central   quote/reply + tips
Avatar
Nymzavril
Member
  • JoinedApr 2014
  • Posts 23802
  • Reviews 280
  • Kudos18270
I just double checked mine, and it definitely works as it should. Could there be an issue with one of your cells? If you've got five or more 18650s, it might be worth switching them out one bay at a time, and seeing if the rate ups to half an amp. I honestly can't think why that would happen, but for the sake of a thirty second test, I guess it's worth kicking it off the list of possible options.
Grand Poobah of The Sacred Order of The Magick Blue Screwdriver. The old Juice Junkies FAQ and guides can be found here: https://www.dropbox.com/sh/vp4ktp8l7fdywg5/AABFkmnUJhjl9vX8tE4URZ8sa?dl=0
#5 (permalink)      6/29/2015 6:16:26 AM US Central   quote/reply + tips
Avatar
Nymzavril
Member
  • JoinedApr 2014
  • Posts 23802
  • Reviews 280
  • Kudos18270
+1 details
Maui_Dave wrote:

I am using a 2.1a Samsung USB plug and mine charges all 4 ports at 500ma. Are you sure your charger plug is actually producing 2.4a? Sometimes the plug is rated to produce 2.4a but is actually faulty and mot putting out the voltage it should.

Do you have one of these to test your wall plug? SKU 1859500



Those things are really handy if you're having charging issues. Mine has just revealed something awry with my tablet, and when faced with £20 for a new battery plus associated aggravation fitting it, I just bought a new Nexus 7.

Grand Poobah of The Sacred Order of The Magick Blue Screwdriver. The old Juice Junkies FAQ and guides can be found here: https://www.dropbox.com/sh/vp4ktp8l7fdywg5/AABFkmnUJhjl9vX8tE4URZ8sa?dl=0
#6 (permalink)      6/29/2015 9:22:08 AM US Central   quote/reply + tips
Hiko9
Member
  • JoinedJun 2013
  • Posts 5641
  • Reviews 269
  • Kudos5408
yeah the cells charge fine on my VP1 - and i've also tried some he1s and efest purples, same thing

i do have the charger doctor, several in fact lol should give it a whirl but i think its either the cable or the charger
Green Screwdriver for LIFE
#7 (permalink)      6/29/2015 10:02:32 AM US Central   quote/reply + tips
JackRussell
Member
  • JoinedJul 2014
  • Posts 70
  • Reviews 208
  • Kudos28
+1 details
My guess would be the cable or your wall wart. Have tried each slot individually? All 3 possible 2 amp confiigurations (Slot 1&4, slot 1&2&3, Slot 2&3&4)? Charge doctor can help identify problems, but it can also introduce some. My VC2 would not charge at full output when I had the charge doctor inline with it.

My VC2 seems to prefer when it's being fed 5.2-5.3 volts. Shorter and thicker cables will have the least losses. I'm waiting for these cables SKU 1355900 to arrive and see how well they work.

Good luck.

**Edit** I just noticed that you said it charges 3@500. It should manage a total of 2A unless you are using both slot 2&3 plus another, and output is 2 shared 1 amp supplies.

Edited on 6/29/2015 at 10:16 AM. Reason: Fun
#8 (permalink)      6/29/2015 10:45:20 AM US Central   quote/reply + tips
Hiko9
Member
  • JoinedJun 2013
  • Posts 5641
  • Reviews 269
  • Kudos5408
It's the wall wart

4.98v

contacting the shop i bought it from

edit: Jack - the samsung 5.3v 2.0a (ep-ta10uwe in the UK) should be great for your vc2 (if it really is 5.3v), it's a little bit too close to the VC4 for me but the 2 should love it. They're dirt cheap too

Edited on 6/29/2015 at 10:56 AM. Reason:
Green Screwdriver for LIFE
#9 (permalink)      6/29/2015 11:40:22 AM US Central   quote/reply + tips
JackRussell
Member
  • JoinedJul 2014
  • Posts 70
  • Reviews 208
  • Kudos28
I'm using an old authentic Samsung 1 amp charger that came with my phone and it's working fine with my VC2 as long as I don't hook the charge doctor to it at the same time. I think there is some play in the charge doctor' usb plug that is causing the decreased output.

I'm still waiting to receive my VC4 and the power supply that I ordered for it. Unfortunately lygte-info has not reviewed the supply I ordered, so it will be a bit of a gamble. I went overkill with the supply so that I could charge multiple things at the same time. The safety of the supply is what I'm more worried about.

It's tough to know if you'll receive authentic Samsung goods when ordering online. The market seems pretty saturated with fakes.

Hopefully you have traced the root of your VC4 issues.
#10 (permalink)      6/29/2015 12:48:15 PM US Central   quote/reply + tips
Avatar
Gwailo
Member
  • JoinedFeb 2014
  • Posts 2735
  • Reviews 87
  • Kudos3434
soak it in vinegar overnight, i hear that helps boost the amperage.
#11 (permalink)      8/5/2015 1:16:10 PM US Central   quote/reply + tips
Avatar
Watercool
Member
  • JoinedDec 2013
  • Posts 10516
  • Reviews 307
  • Kudos8083
Mine worked fine and does .2 now on slot 1 and 4. No clue why. Goes up to 1 amp for a second and then throttles down.