shopping cart empty
WORLDWIDE FREE SHIPPING

Center pin
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#11 (permalink)      12/8/2013 10:06:56 AM US Central   quote/reply + tips
Gwapinco
Member
  • JoinedAug 2013
  • Posts 50
  • Reviews 13
  • Kudos12
Have you fixed the leak? If not, make sure when you lock things in, the small rubber o-ring is blocking the hole. This would be the o-ring around the center pin where you put the wires.
#12 (permalink)      12/8/2013 12:57:32 PM US Central   quote/reply + tips
mvanja
Member
  • JoinedAug 2013
  • Posts 4
  • Reviews 5
  • Kudos0
Thanks G for the reply, it is licking through the pin and from the spot U mentioned, the pin is not straight so there is no perfect match with the hole
#13 (permalink)      1/8/2014 12:59:25 AM US Central   quote/reply + tips
AbsyX
Member
  • JoinedOct 2013
  • Posts 5
  • Reviews 0
  • Kudos0
I have had this for a month working great with many builds until now the centre pin has no connectivity, tried 10 or so rebuilds with new wires but still have no luck, the full centre pin including the brass bottom has died for good! Anyone know what I can do? Is there replacement parts? Or will fast tech cover it under the 60days warrenty?
#14 (permalink)      1/12/2014 3:13:33 PM US Central   quote/reply + tips
Jargon
Member
  • JoinedFeb 2013
  • Posts 85
  • Reviews 0
  • Kudos13
I received my Ithaka about 2 weeks and had not set it up till tonight! Damn it the center pin was at a bad condition with clear marks of abuse! It was bent and had signs of force used against by pliers. I tried to unscrew the brass part (was not making contact - too recessed) and it broke!

This must have been a return or somebody at the factory tried a "quick" fix (bent) and ruined it.

AbysX have you managed to find a solution with yours? Are there parts available?

I will contact CS but it sucks to have to wait till mid February even if they send a replacement part. My other option since I live in Greece is to buy an original center pin but the damn thing costs 20 Euros with shipping which is no good for an clone costing close to that. I didn't even have the chance to try it out.
#15 (permalink)      1/12/2014 3:21:28 PM US Central   quote/reply + tips
AbsyX
Member
  • JoinedOct 2013
  • Posts 5
  • Reviews 0
  • Kudos0
I contacted ft under its 6months warrenty, they asked me to send pics attached of part, waiting for responce, seems like it will possibly be replaced by them, let's wait & see
#16 (permalink)      1/12/2014 4:40:52 PM US Central   quote/reply + tips
Jargon
Member
  • JoinedFeb 2013
  • Posts 85
  • Reviews 0
  • Kudos13
Thanks for the reply AbsyX. I opened a ticket too and send pictures too so I hope they find some parts for us.

With that said the broke pin is certainly not SS. The section of the cut is kinda yellowish - white but I might be wrong. I don't know what broken SS looks like but I know that when cut (big parts I have seen in construction works) it does not look like that and honestly I would not expect it to break that easy. Anyway, FT support has never let me down to be honest.
#17 (permalink)      1/13/2014 7:26:51 AM US Central   quote/reply + tips
AbsyX
Member
  • JoinedOct 2013
  • Posts 5
  • Reviews 0
  • Kudos0
Hi Jargon

Are you sure it's not the brass yellow part that's worn out,, I reckon mine is the same too but I know that's not meant to be ss and it's brass like the originals.. Mine worked over a month till it burnt out due to using mechanical mods.. But again that shouldn't matter if it's a solid product, perhaps it's because it's a clone.. After 6 months yes we will need to find original replacement part or someone who does a clone for the centre post.. Not bad buying a new one all in as it's not that expensive.

They have sent me replacement product in my new shipment.. I am sure they will send you one out too as FT have been great in resolving issues with products, warrenty & shipments!

The device is top notch,, one of my fav rebuildables now even thow it's a clone, it gives out warm & cool vape at your choice, throws some serious flavour & can be ran at .8.9 1ohm easily.

Hope u get it working

Happy Vaping Pal
#18 (permalink)      1/14/2014 3:55:46 AM US Central   quote/reply + tips
Jargon
Member
  • JoinedFeb 2013
  • Posts 85
  • Reviews 0
  • Kudos13
AbysX it's not the brass part that broke. Here:



Do you see the deep scratches? I received it like that so force had be used in it by someone.

This specific part costs 15.5 Euros (the long pin) to get the original plus only 3 Euros shipping since I live in Greece and can buy it locally. The brass part now is cheap though only 3 Euros. Anyway, I am sure they will help me out as they always do.
#19 (permalink)      1/15/2014 12:03:08 PM US Central   quote/reply + tips
Jargon
Member
  • JoinedFeb 2013
  • Posts 85
  • Reviews 0
  • Kudos13
Ok, they sorted it out! Replacement on its way with an unshipped order.
#20 (permalink)      1/15/2014 12:05:04 PM US Central   quote/reply + tips
AbsyX
Member
  • JoinedOct 2013
  • Posts 5
  • Reviews 0
  • Kudos0
Awesome, yeh they only added it to my order as it's coming to same addy or else would have been without additional order like yours, I felt like a kayfun lol happy vaping pal
#21 (permalink)      3/27/2014 4:11:42 AM US Central   quote/reply + tips
bill36au
Member
  • JoinedOct 2013
  • Posts 2
  • Reviews 84
  • Kudos0
I received mine today. The center post is missing the air hole drilled sideways into the center shaft and would not let any air flow through to the coils.

I checked on my other Ithaka clone and it had this hole.

I have raised a ticket and hope it gets sorted out soon.