shopping cart empty
WORLDWIDE FREE SHIPPING

Vamo V3 Firing Issue
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      7/31/2013 2:25:05 PM US Central   quote/reply + tips
Jack916
Member
  • JoinedJul 2013
  • Posts 11
  • Reviews 0
  • Kudos0
Vamo V3 Firing Issue
any one else having an issue with the vamo cutting in and out while firing? i stretched out the battery coil but it is still doing it. not sure if this is a security feature so that the cartomizer doesn't burn up.
#2 (permalink)      7/31/2013 3:40:05 PM US Central   quote/reply + tips
Waggs
Member
  • JoinedJun 2013
  • Posts 115
  • Reviews 15
  • Kudos44
Details please. :) Sounds like a bad coil in your atomizer. Also, the center pin on either the Vamo or tank could be pushed in too far.

What are you using for an atomizer?
Did you check the ohms of the atty via the Vamo?

Edited on 7/31/2013 at 3:50 PM. Reason:
#3 (permalink)      7/31/2013 8:41:50 PM US Central   quote/reply + tips
Jack916
Member
  • JoinedJul 2013
  • Posts 11
  • Reviews 0
  • Kudos0
I'm using a 510 xl 3ohm cartomizer vaping at 10 watts. Tried other cartomizers all are xl 510 3ohms. Ive tried turning down the watts as low as 7 watts still the same issue.
#4 (permalink)      7/31/2013 10:28:44 PM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 31280
  • Reviews 14
  • Kudos61623
+1 details
Vaping at pretty high watts there . Are you using 18650 ?

To get the full potential when vaping at higher voltages from the vamo.

If your at 10watts OR over I believe you need to have 2 18350's in it.

Is you battery getting hot ?

The battry might be cutting out cause it cannot HANDLE THE HIGH WATTS

Try lowering the wattage to see if that stops it or try lower resistance carto

Edited on 7/31/2013 at 10:40 PM. Reason:
https://i.imgur.com/OSS6yni.jpg
#5 (permalink)      8/2/2013 12:14:27 AM US Central   quote/reply + tips
Jack916
Member
  • JoinedJul 2013
  • Posts 11
  • Reviews 0
  • Kudos0
i have been using a 18350 battery but it also cuts out when i use my 18650 battery. i tried stretching the batter coil to no avail. i have vaped as low as 7 watts with the same firing cutting in and out.
#6 (permalink)      8/2/2013 12:26:07 AM US Central   quote/reply + tips
Waggs
Member
  • JoinedJun 2013
  • Posts 115
  • Reviews 15
  • Kudos44
Check your center pin on the Vamo to see if it is pushed down into the washer (white on mine) or if there is damage to the washer. This has been a common problem with screwing on a tank too tight and pushing the center pin down.

Do you have anything with lower resistance that you can test on it?

Edited on 8/2/2013 at 12:28 AM. Reason:
#7 (permalink)      8/2/2013 2:57:03 PM US Central   quote/reply + tips
Jack916
Member
  • JoinedJul 2013
  • Posts 11
  • Reviews 0
  • Kudos0
i recently tried a 2ohm carto and a 2.2 ohm cartomizer. it is reading .1 off on the ohm meter on the vamo. so instead of saying 3 ohms or 2.2 ohms it will read 2.1 ohm and 2.9 ohms. anyway to pull the center pin up so that the center pin won't slide back down as soon as you connect another cartomizer to it?
#8 (permalink)      8/15/2013 12:17:15 PM US Central   quote/reply + tips
rsilva708
Member
  • JoinedJun 2013
  • Posts 1
  • Reviews 1
  • Kudos0
Mine died in less than 2 months.Started with a hit or miss fire when pressing the fire button, and now you can't get enough good clicks in a row to turn it on. Thinking maybe a bad solder connection for the button. Back using my V2. Not sure I'll be getting another Vamo.