Free shipping to the United States when you order $20+

Boken on the first day of use
Login to post a new topic and to write a reply.
Thread Tools


Search within thread:

Rate This Thread
Login to rate this thread.
#1 (permalink)      9/29/2013 3:32:28 PM US Central   quote/reply + tips
filmnazi
Verified
  • JoinedSep 2013
  • Posts 4
  • Reviews 0
  • Kudos0
Boken on the first day of use
My new SVD from Fasttech is broken after just a few hours use. Any tank I put on it including the iClear 30s that came with it register at 0.0 ohms (0.0A in Innokin talk). It won't fire and I am very, very sad as I researched for weeks and waited over two weeks to get it. If anyone has any suggestions I would love the help.
#2 (permalink)      9/29/2013 3:39:20 PM US Central   quote/reply + tips
AlexMci
Verified
  • JoinedJul 2013
  • Posts 137
  • Reviews 0
  • Kudos74
+3 details
Not a pro by any means mate, but I would check that you have not pushed the centre pin in to far. Try and wiggle it out a touch with a small screwdriver or something of that sort. It's spring loaded but I had this happen after using an airflow controller with my protank. I unscrewed it and my i30 wouldn't work. A wee pull up of the centre pin and I was off again. The SVD I got seems bulletproof. In fact I have just ordered a back up. If that's not what's wrong I'm sorry but you may have to return it bud.
#3 (permalink)      9/29/2013 4:28:38 PM US Central   quote/reply + tips
hellhound
Verified
  • JoinedJun 2013
  • Posts 1064
  • Reviews 21
  • Kudos1392
+2 details
Alex is BOB ON with his Post matey .... Pop up the centre pin (as alex says its Spring loaded) .. & stick a VERY VERY VERY SMALL amount of Grease on it (so it wont stick again) ...

SVD's are Totally bullet proof (you can use them as HAMMERS!!!!) ...

HH
I am somewhat of a bullshitter myself but occasionally I like to listen to a real Pro, Please, do carry on
#4 (permalink)      9/29/2013 5:17:37 PM US Central   quote/reply + tips
MarkFll
Verified
  • JoinedSep 2013
  • Posts 84
  • Reviews 0
  • Kudos46
+1 details
That's good to know. Mine SVD is on it's way from San Fransisco to Florida. I'm really careful with my Vamo V3 as well after hearing about some people screwing their accessories on too tight. I have 2 older KGO batteries and on one of them, I have to constantly pull the pin up. But it always works again.
#5 (permalink)      9/29/2013 5:33:38 PM US Central   quote/reply + tips
filmnazi
Verified
  • JoinedSep 2013
  • Posts 4
  • Reviews 0
  • Kudos0
When you say center pin you mean the round brass thing inside the piece you screw the tanks onto?
#6 (permalink)      9/29/2013 5:48:12 PM US Central   quote/reply + tips
bumbleballs
Verified
  • JoinedJan 2013
  • Posts 1235
  • Reviews 26
  • Kudos1345
yes :)
#7 (permalink)      9/29/2013 5:51:15 PM US Central   quote/reply + tips
AlexMci
Verified
  • JoinedJul 2013
  • Posts 137
  • Reviews 0
  • Kudos74
Yes mate, turn the mod off and gently work the pin out with a toothpick or get a hold of it with a pair of tweezers. Sounds as if it's not making contact with the bottom post of your tanks. Thus no coil resistance showing on the mod.
#8 (permalink)      9/29/2013 5:55:23 PM US Central   quote/reply + tips
filmnazi
Verified
  • JoinedSep 2013
  • Posts 4
  • Reviews 0
  • Kudos0
Ok so the center pin is not stuck, it moves up and down freely...
#9 (permalink)      9/29/2013 5:57:58 PM US Central   quote/reply + tips
Gems295
Verified
  • JoinedMar 2013
  • Posts 625
  • Reviews 61
  • Kudos715
+2 details
The iclears that won't work on your SVD?? can you try them on something else? see if they work?
Sounds like it's shorted, showing 0.0a and probs blown the heads? Try a new head in your iclear or different clearo? Start with low ish watts and increase til you get it to your taste.

My mate in the first day of her SVD, cranked the volts up too high and fried the heads on 2, yes, bl**dy 2 iclears, i got the frantic "My SVD has broke" phone call.

Anyway, just try it.
Vaping since April 2008 and still loving it :) Stopped smoking April 2008, soooooooo easy :)
#10 (permalink)      9/29/2013 5:58:18 PM US Central   quote/reply + tips
AlexMci
Verified
  • JoinedJul 2013
  • Posts 137
  • Reviews 0
  • Kudos74
Well when you have pulled it up try a tank on it, it should now read the ohm of the coil in said tank, if not something's wrong with it mate. The only suggestion I have is a dodgy coil on the i30, if not something is not completing the circuit so something's not working correctly.
#11 (permalink)      9/29/2013 5:59:32 PM US Central   quote/reply + tips
filmnazi
Verified
  • JoinedSep 2013
  • Posts 4
  • Reviews 0
  • Kudos0
iClears nor Evod work on SVD both work fine on my Vamo V3