shopping cart empty
WORLDWIDE FREE SHIPPING

Why does my SVD always turn itself off?
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      7/3/2014 1:56:32 AM US Central   quote/reply + tips
dannieboiz
Member
  • JoinedNov 2013
  • Posts 30
  • Reviews 0
  • Kudos3
Why does my SVD always turn itself off?
My SVD doesn't want to stay on. I'll be taking a couple hits then it would turn off. Tried different batteries same thing. Checked my button as some suggested and all seems snug. I think this is electrical and not mechanical issue. Does anyone else have this issue?
#2 (permalink)      7/3/2014 2:20:39 AM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 26719
  • Reviews 14
  • Kudos51057
+2 details
Are you using protected or unprotected batteries?

The SVD prefers unprotected as a protected battery conflicts with the SVD built in protection causing it to shut down.

If that isn't it you may have a short in the atomizer causing it to trip protection (try different atomizer or coil).


Also if you overtightened your atomizer you may have pushed the firing pin in the 510 connector down causing a short tripping protection. Try to raise firing pin slightly with small screwdriver (just a mm or so).
http://i.imgur.com/fKSQtVA.jpg..........You self made victims crack me up. =D
#3 (permalink)      7/3/2014 2:25:39 AM US Central   quote/reply + tips
Avatar
franzy29
Member
  • JoinedApr 2014
  • Posts 2919
  • Reviews 227
  • Kudos21335
@dannieboiz

I used to have this problem...using aerotanks and protanks

I noticed that switching the coils, or better, rebuilding them by myself, completely solved the problem...

Hope that will help you
FT French Connection > http://www.fasttech.com/forums/-/t/1333225/-/last ///////////////////////////////////////// Groupe Caribook > https://www.facebook.com/groups/frenchiesFT/
#4 (permalink)      7/3/2014 2:45:49 AM US Central   quote/reply + tips
dannieboiz
Member
  • JoinedNov 2013
  • Posts 30
  • Reviews 0
  • Kudos3
tried 3 different atomizer, Kraken Genesize, KFL and Protank, and 4 different coil builds same thing. I'm using unprotected sony batteries works fine on my vamo v3. The SVD was working fine for the first week or so then things went down hill.
#5 (permalink)      7/3/2014 11:03:00 AM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 26719
  • Reviews 14
  • Kudos51057
+1 details
Have you tried to raise the 510 center pin?


Here is a video on how to do it (works on most mods not just EGOs)

Center Pin Issue


If that doesn't work then you may want to put in for a warranty replacement.


Item defective



This item is covered by FastTech's Standard Return Policy:

Product Warranty (faulty / defective over normal use)
http://i.imgur.com/fKSQtVA.jpg..........You self made victims crack me up. =D
#6 (permalink)      11/4/2014 2:20:16 AM US Central   quote/reply + tips
yves59
Member
  • JoinedNov 2013
  • Posts 87
  • Reviews 37
  • Kudos18
hello,
I use the SVD for almost a year now. At first I had some problems as many of vous.Il went out constantly
I cleaned the inside of the tube with a toothbrush and alcohol and then wipe dry with paper towels. Then I put in the tubes and the 510 connection cleaner electrical contactor (KF F2)
I do this regularly and more problems.
That if little help.