shopping cart empty
WORLDWIDE FREE SHIPPING

Major issues with my svd. PLEASE HELP
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      12/30/2013 12:14:16 PM US Central   quote/reply + tips
spiffy01
Member
  • JoinedJul 2013
  • Posts 180
  • Reviews 10
  • Kudos32
Major issues with my svd. PLEASE HELP
So I have my svd for 3 days now, and having endless issues with it.

I'm using a 18650 battery, which is fully charged, with a pro tank one, evod and steam turbine- all of which when I connect to the svd shows me 0.0v and the battery as well.

What am I doing wrong here as this is driving me past insane.

I tried pulling the pins a little out of each of the attys, all with the same result.

I tried each of the attys on my ego slb and all are working fine.

What could be the issue here?

Please help me.
#2 (permalink)      12/30/2013 12:25:54 PM US Central   quote/reply + tips
rustynail
Member
  • JoinedJun 2013
  • Posts 196
  • Reviews 28
  • Kudos72
Mine is defective as well. The pulse is fubar it will pulse to what I have my volts at and then drop down to 2 volts. It also is producing a electronic buzz and has shocked me. Sending it back you should do the same.
#3 (permalink)      12/30/2013 12:31:35 PM US Central   quote/reply + tips
MaxBargain
Member
  • JoinedSep 2013
  • Posts 58
  • Reviews 9
  • Kudos37
I don't know....if that helps at all lol. Is it just the display..does it work in any way? When the battery is low it just says 'low' and turns off...If you've tried multiple atomizers and they're working fine,,the battery is definitely ok, and it's not a display issue (not heard of this but trying to think what it could be)- might be a faulty SVD...honestly really like mine and works perfectly.
#4 (permalink)      12/30/2013 12:36:03 PM US Central   quote/reply + tips
Avatar
foxey
Member
  • JoinedJun 2013
  • Posts 3477
  • Reviews 77
  • Kudos2608
0.0v thats anew one on me ? err.non is the ones that i have seen .
even if you put flat battery below 3.0v it wont boot up.
but 3.0v or above you will get red orange or green lights for battery indication.
sounds like its a malfunction ?if no atty on it does it say non on the screen?
I told you so !
#5 (permalink)      12/30/2013 12:36:54 PM US Central   quote/reply + tips
MaxBargain
Member
  • JoinedSep 2013
  • Posts 58
  • Reviews 9
  • Kudos37
Just out of interest..were these definitely genuine Innokin SVDs?
#6 (permalink)      12/30/2013 12:41:15 PM US Central   quote/reply + tips
Avatar
foxey
Member
  • JoinedJun 2013
  • Posts 3477
  • Reviews 77
  • Kudos2608
oh no not that old yarn again ?
I told you so !
#7 (permalink)      12/30/2013 12:46:33 PM US Central   quote/reply + tips
MaxBargain
Member
  • JoinedSep 2013
  • Posts 58
  • Reviews 9
  • Kudos37
Well..just wondering as I was thinking of buying another one and yes...did hear some concerns raised..not sure how seriously to consider them?
#8 (permalink)      12/30/2013 1:26:24 PM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 26700
  • Reviews 14
  • Kudos51033
+1 details
spiffy01

0.0 is a short from the firing pin in the 510 connecter. You may have overtightened one of your items on it. You should try to raise the firing pin on the SVD and not the atomizer as it will push it down further.

If it is a short at the connector you can fix it with a new o-ring from the hardware store.

Here is a video to show you how. It is for a Vamo but works on the SVD also.

How to fix a Vamo or Bamboo with Low Ohms (click here)

You may just get away with raising the center pin like on this EGO battery video.

Center Pin Issue (click here)

By the way it can't be 0.0v (completely dead battery) or you wouldn't even see it light up to see numbers.

It is showing you 0.0ohms which is a short for sure.

Edited on 12/30/2013 at 1:30 PM. Reason:
http://i.imgur.com/fKSQtVA.jpg..........You self made victims crack me up. =D
#9 (permalink)      12/30/2013 1:27:22 PM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 26700
  • Reviews 14
  • Kudos51033
+2 details
MaxBargain

They are authentic for sure. No concerns ;)
http://i.imgur.com/fKSQtVA.jpg..........You self made victims crack me up. =D
#10 (permalink)      12/30/2013 1:30:15 PM US Central   quote/reply + tips
afrhino
Member
  • JoinedSep 2013
  • Posts 483
  • Reviews 47
  • Kudos580
+1 details
@Spiffy,

It might even be easier than what Viking said. The instruction manual is wrong. The battery inserts + (nipple side) first. If you insert it the way the manual says (- first), depending on the battery you'll get 0.0V.

Edited on 12/30/2013 at 1:30 PM. Reason:
Death is lighter than a feather, duty heavier than a mountain.
#11 (permalink)      12/30/2013 1:33:37 PM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 26700
  • Reviews 14
  • Kudos51033
+2 details
Forgot that one afrhino good catch ;)

@Spiffy

The manual is wrong most defiantly as afrhino has pointed out (nipple side first)

Also you haven't stated if batteries are protected or unprotected.

The SVD does not like protected batteries as it has its own built in protection

Use unprotected in the SVD

Edited on 12/30/2013 at 1:34 PM. Reason:
http://i.imgur.com/fKSQtVA.jpg..........You self made victims crack me up. =D