shopping cart empty
WORLDWIDE FREE SHIPPING

Is my SVD broken or is it something else?
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      10/28/2013 11:44:59 AM US Central   quote/reply + tips
DimitroffVodka
Member
  • JoinedJun 2013
  • Posts 2
  • Reviews 0
  • Kudos0
Is my SVD broken or is it something else?
I have a SVD and I am using these batteries, http://www.fasttech.com/product/1435600 with these Atmotizers http://www.fasttech.com/product/1307200

My SVD keeps automatically turning off while in use. Only way to turn it back is take out the battery and reinsert it. I have tried a wide range of wattage and voltage but seems to make no difference. It sometimes works for awhile with no problems while other times it won't work even one time.

I ordered some Panasonic batteries in case that is the issue and a new Atmoizer that operates at a lower OHM. Not sure what the issue is though for sure. Not sure if I should RMA or not.
#2 (permalink)      10/28/2013 11:57:13 AM US Central   quote/reply + tips
SkeetS
Member
  • JoinedJul 2013
  • Posts 149
  • Reviews 41
  • Kudos63
Well...All i can say is that you should get new batteries.
Those brown ones won't even fire on a mechanical mod a 3ohm atomizer and when they do...won't last long.
Possibly the worse batteries i ever got were those.

BOTTOM LINE: Problem is the battery...
#3 (permalink)      10/28/2013 11:57:47 AM US Central   quote/reply + tips
bimmernut318
Member
  • JoinedMar 2013
  • Posts 48
  • Reviews 0
  • Kudos34
You are probably drawing too many amps and the SVD shuts itself off, those batteries are pretty crappy and if you are using that charger you may want to think about getting a better one of those too.
#4 (permalink)      10/28/2013 12:11:49 PM US Central   quote/reply + tips
DimitroffVodka
Member
  • JoinedJun 2013
  • Posts 2
  • Reviews 0
  • Kudos0
I ordered these Panasonic batteries, http://www.fasttech.com/product/1141104

Hopefully that takes care of the issue. My first though was the batteries since one of the batteries works much better than other
#5 (permalink)      10/28/2013 12:15:21 PM US Central   quote/reply + tips
x3raptor
Member
  • JoinedAug 2013
  • Posts 530
  • Reviews 102
  • Kudos300
+2 details
more than likely your problem here is the "Protected Li-Ion Battery" the svd has it's own protection, use an IMR ((un-protected)) battery and your issue should be gone. XD
SVT Raptor
#6 (permalink)      10/28/2013 6:10:31 PM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 26700
  • Reviews 14
  • Kudos51033
Yup SVD doesn't like protected

SKU 1141100 will work for sure =D

Edited on 10/28/2013 at 6:12 PM. Reason:
http://i.imgur.com/fKSQtVA.jpg..........You self made victims crack me up. =D
#7 (permalink)      10/29/2013 2:20:33 PM US Central   quote/reply + tips
VapeTek
Member
  • JoinedJun 2013
  • Posts 68
  • Reviews 28
  • Kudos46
I've had this issue as well with both my SVD's using protected and unprotected Panasonic NCR18650B. It doesn't happen very often tho.