shopping cart empty
WORLDWIDE FREE SHIPPING

are these better than the regular 1300mah egos?
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      10/24/2013 2:07:09 PM US Central   quote/reply + tips
rmrfyou
Member
  • JoinedMar 2013
  • Posts 254
  • Reviews 35
  • Kudos41
+1 details
are these better than the regular 1300mah egos?
I had a regular $6.xx 1300mah die on me after a day. The switch would light up but didn't power my atties. Ate these better for $2 more?
#2 (permalink)      10/24/2013 2:44:03 PM US Central   quote/reply + tips
iinweed
Member
  • JoinedJul 2013
  • Posts 960
  • Reviews 23
  • Kudos638
+1 details
Sounds like a connection problem. These are likely to be exactly the same.

Have a look at http://www.fasttech.com/forums/vapers/t/1015035/beginners-topics?1016523

Check the connection on the Atty as well, sometimes those get pushed in too.
Never underestimate the power of human stupidity. All opinions expressed are my own.
#3 (permalink)      10/24/2013 4:27:29 PM US Central   quote/reply + tips
Avatar
viking65
Member
  • JoinedJul 2013
  • Posts 26883
  • Reviews 14
  • Kudos51361
+1 details
Yup just follow that video sounds like you overtightened atty or charger and pushed firing pin down to far. A very common issue with any ego

Your battery is more then likely just fine if lights still working =D

Edited on 10/24/2013 at 4:28 PM. Reason:
http://i.imgur.com/fKSQtVA.jpg..........You self made victims crack me up. =D