shopping cart empty
Received different board
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      4/11/2014 11:46:16 AM US Central   quote/reply + tips
geersandwire
Member
  • JoinedNov 2013
  • Posts 2
  • Reviews 0
  • Kudos0
Received different board
Problem: the 1122400 that I ordered was received as a 1122401(very different). The board is clearly marked ak-a1, which is a 1.4 amp. Be careful, I have contacted Fasttech about this.
#2 (permalink)      4/11/2014 12:06:08 PM US Central   quote/reply + tips
Avatar
patmurris
Member
  • JoinedJun 2013
  • Posts 589
  • Reviews 65
  • Kudos304
The 1122401 has two groups of 3 or 5 modes and you can switch from one group to the other when on low mode. It depends how you plan using it, but i find the 2 groups better since you don't have to solder (hardwire) anything and can still hide the strobe and sos modes for everyday use... Both will provide a bit more then 1A (not 1.4A) since they both have 3 x AMC7135.

Edited on 4/11/2014 at 12:07 PM. Reason:
My location: Nice, France.
#3 (permalink)      4/14/2014 8:52:04 PM US Central   quote/reply + tips
rogerjones
Member
  • JoinedMar 2014
  • Posts 1
  • Reviews 1
  • Kudos0
same problem here, sent me wrong items aswell, and not getting any replys from them should be called sorrytech.com not fasttech.com
#4 (permalink)      6/20/2015 12:25:33 AM US Central   quote/reply + tips
mobydimk
Member
  • JoinedJan 2014
  • Posts 20
  • Reviews 4
  • Kudos7
looks like FT got correct items, yesterday received driver exactly like at pictures.