Free shipping to the United States when you order $20+

Doesn't charge 18350 batteries
Login to post a new topic and to write a reply.
Thread Tools


Search within thread:

Rate This Thread
Login to rate this thread.
#1 (permalink)      5/21/2013 1:34:15 PM US Central   quote/reply + tips
awepa
Verified
  • JoinedMar 2013
  • Posts 1
  • Reviews 0
  • Kudos0
Doesn't charge 18350 batteries
Hi,
I bought this charger and I have problem with charging new batteries protected 18350. After a few minutes the light change to green and stop charging. Does anybody know what's going on? Can i do something to fix it? I doubt that the batteries are bad... Might i should remove protection kit?

Best regards,
AW
#2 (permalink)      5/21/2013 4:44:50 PM US Central   quote/reply + tips
nick_ft
Verified
  • JoinedMar 2013
  • Posts 25
  • Reviews 0
  • Kudos11
+1 details
I hope you slid the switch (3.0V to 4.2V). Try to leave your battery for a longer time in a charger. Hopefully green light will change to red after a while.
Sometime your 4.2V battery discharges to the 2.5-3.0V level and the charger might think that you have 3.2V battery (LiFePO4).
#3 (permalink)      5/31/2013 1:35:19 AM US Central   quote/reply + tips
Avatar
geek
Tech Staff
  • JoinedJun 2012
  • Posts 3424
  • Reviews 19
  • Kudos4445
We have just tested this charger with a 18350 and it works fine. Like @nick_ft said, please make sure you switched to 4.2V and make sure your battery's +/- contacts are securely pressed against the charger.
All questions and comments are welcome. We are here to help.
#4 (permalink)      10/1/2013 12:43:59 PM US Central   quote/reply + tips
Avatar
foxey
Verified
  • JoinedJun 2013
  • Posts 3812
  • Reviews 87
  • Kudos2989
+1 details
also i have noticed sometimes as batt warms up whilst charging, they move in contacts tricking you into thinking that their fully charged, if you move them slighty they go back to charging,
just keep your eye on charger ;)
I told you so !free at last
#5 (permalink)      11/20/2013 6:07:49 AM US Central   quote/reply + tips
huseyno
Verified
  • JoinedJul 2013
  • Posts 9
  • Reviews 0
  • Kudos1
I also have the same problem. I put an efest 18350 3,7V imr battery. It charges a few seconds then the red light turns to green. The switch is on 4.2V. How can I solve this problem?
P.S. My other charger TR-001 works fine with my batteries.

Edited on 11/20/2013 at 6:13 AM. Reason:
#6 (permalink)      3/31/2014 8:11:50 AM US Central   quote/reply + tips
gentroid
Verified
  • JoinedFeb 2014
  • Posts 91
  • Reviews 32
  • Kudos28
Same here, flat top batteries...