shopping cart empty
Ego batteries defect or not compatible?
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      7/15/2013 8:41:48 PM   quote/reply + tips
aznsky2000
Member
  • JoinedJul 2013
  • Posts 5
  • Reviews 0
  • Kudos5
+1 details
Ego batteries defect or not compatible?
Hi, can anyone tell me if these two batteries are defect or it's just not compatible with the atomizers I bought. When I put them together and press the button, it flashes three times. Then, the light just stays on. When I press it again, nothing happens. I thought it ran out of battery, but when I connect it to the eGo charger(input:DC 5V 500mA, Output: DC 4.2V 420mA) nothing happens, the lights on the charger just stays green. I know it's not the atomizers problem because I tried it on my old batteries (eGo-T 1000mAh) and it worked fine. So, did I purchase the wrong batteries for the



Batteries:
900mAh
650mAh

Tanks:
Tank1
Tank2
Tank3

Edited on 7/15/2013 at 8:44 PM. Reason: fixed link
#2 (permalink)      7/15/2013 8:42:57 PM   quote/reply + tips
mustangmadonna
Member
  • JoinedMay 2013
  • Posts 62
  • Reviews 21
  • Kudos28
+1 details
try a different charger
non-smoker since April 23,2010
#3 (permalink)      7/15/2013 8:45:24 PM   quote/reply + tips
aznsky2000
Member
  • JoinedJul 2013
  • Posts 5
  • Reviews 0
  • Kudos5
+1 details
wow fast reply ^^. But is it normal for the lights to stay on light that?
#4 (permalink)      7/15/2013 9:01:22 PM   quote/reply + tips
Gems295
Member
  • JoinedMar 2013
  • Posts 625
  • Reviews 58
  • Kudos708
+1 details
A couple of people at work have had the same problem as you. Both bought 900mah, both using 2.8 attys, one battery had only been used for one day, flashed 3 times and the led stayed permanently on, the 2nd worked ok for approx a week, then the same thing happened. The led shouldn't stay on like that.

Edited on 7/15/2013 at 9:17 PM. Reason:
Vaping since April 2008 and still loving it :) Stopped smoking April 2008, soooooooo easy :)
#5 (permalink)      7/15/2013 9:39:40 PM   quote/reply + tips
aznsky2000
Member
  • JoinedJul 2013
  • Posts 5
  • Reviews 0
  • Kudos5
+1 details
Hmmm...ok so I'm not alone in this then. Guess need to return them -_-
#6 (permalink)      7/16/2013 2:16:34 AM   quote/reply + tips
NoneGiven2
Member
  • JoinedApr 2013
  • Posts 1466
  • Reviews 25
  • Kudos1254
+1 details
Sometimes a wall charger can help reset eGo batteries that are acting up. Have you tried connecting them to a wall charger yet? If not try it and see if they correct themselves after a minute or two

Also, what happens if you shut them off (5-click) and trn back on? Same, lights stay on after that too?

Lights should not stay on (Unless charging), that normally means they are outputting power, so not good.

Might have to return these as you suspected, it doesn't look good!
#7 (permalink)      7/16/2013 1:35:28 PM   quote/reply + tips
aznsky2000
Member
  • JoinedJul 2013
  • Posts 5
  • Reviews 0
  • Kudos5
+2 details
I've tried the 5 clicks but nothing happens. Weird thing is that when I plug one of the batteries in the USB charger, the lights flashes 3X, but not always. The other just stays blue. This morning both battery lights went off, which I believe it ran out. Now for sure the button/click is stuck inside. I only have one charger, I might as well get a wall charger for back up...Waiting for RMA status -_-...I've waited for almost two weeks for this to deliver from Hong Kong >.<.
#8 (permalink)      7/16/2013 1:48:42 PM   quote/reply + tips
NoneGiven2
Member
  • JoinedApr 2013
  • Posts 1466
  • Reviews 25
  • Kudos1254
Sorry to hear! Now that they're dead, did you test to see if they'll charge properly again?

Can you fiddle, side click, ect with the button and see if it'll unstick? Do they look pressed in there incorrectly?
#9 (permalink)      7/16/2013 2:24:13 PM   quote/reply + tips
aznsky2000
Member
  • JoinedJul 2013
  • Posts 5
  • Reviews 0
  • Kudos5
I did tried to press the button from different angles but no use. I don't want to break into the thing a poke around with as the battery is fixed, will break the warranty. ; ; still no reply from staff >.<
#10 (permalink)      7/23/2013 3:46:49 AM   quote/reply + tips
lydia
Staff
  • JoinedJul 2013
  • Posts 600
  • Reviews 0
  • Kudos198
We have consulted our supplier and haven't been told that maybe the circuit board components are burnt.
**Please post your order nunber** when asking order specific questions. Thank you.
#11 (permalink)      7/23/2013 4:32:22 AM   quote/reply + tips
Amiga72
Member
  • JoinedApr 2013
  • Posts 1074
  • Reviews 0
  • Kudos1546
when the button light comes on like that it indicates a short on the battery inside now this is normally the wire from the circuit board to the centre pin on the 510 connector but sometimes can be a split in the insulator on the 510 connection or circuit board touching casing. they can be fixed usually by resoldering/replacement of insulator/reseating board depending on which type of short it is.

if you find they work for a while then suddenly stop thats usually centre pin connection and is quite common due to centre pin turning as clearomisers are screwed on and off which stresses the wire connection until snaps.

if it was the button stuck they would auto shut off after 7-10 secs short=light constant.

I have fixed many ego batteries with these problems from bog standard to the twists.

fixing involves removing the head, 510 cartomiser screwed in then wiggle head back and forth gently and it will ease out.

(Note: IF YOU ARE NOT COMFORTABLE TAKING APART, WORKING WITH A SOLDERING IRON OR ELECTRONICS - DO NOT ATTEMPT THIS - IF YOU DONT KNOW WHAT YOU ARE DOING IT CAN BE DANGEROUS)

Edited on 7/23/2013 at 4:50 AM. Reason: